closed
Public

I’m having problems with the simulation and exporting. When I click “Run Simulation”, I briefly (VERY briefly) see an “Action in Progress” message box, and then nothing happens. I am running version 2.15, and I do have the “Allow Active Content to run…” setting checked in internet explorer (IE 7). I’m on XP and currently trying to use the tool at a rather restrictive corporate environment. It could very well be a permissions/group policy issue, but I don’t know what direction to point the IT folks in. Admin access is not an option for me.

Also, when I try to work around this by simply exporting DHTML, it exports everything except for the index.html file, which is obviously quite important.

Everything seems to work fine for me in the browser version of your tool, but the client is having issues. I can have IT upgrade my version to your latest 2.17, but I didn’t see anything in the notes about addressing any issues related to these. help?

7 answers

Hi pohldoug,

You don’t have to get the admin permission to make ForeUI work. Just make sure you have the permission to write the workspace folder. The default location of workspace folder is “C:Documents and Settings<YourUserName>.foreuiworkspace”. If you don’t have the permission to write this folder, or your folder size is limitted, you can move the workspace to another folder (via menu “Advanced->Settings->Misc Tab”).

However I can not understand why the “index.htm” file is not generated while other files are created. Usually it clouldn’t happen unless an error is thrown during the generation. Can you send your plot file to foreui@easynth.com ? I guess your plot file may reproduce the bug on our side.

#1

It appears I do have permission to write to that folder, but just for good measure, I changed the default location as you mentioned. Neither method is producing the desired result.

I have attempted to send my plot file to you, not sure if the attachment will get stripped or not. (As I mentioned above, our company is quite restrictive). It’s not anything special, I just very quickly dragged a couple widgets on because I was just testing some of the software functions. We just purchased a license, but I had tried your online version and liked it very much.

#2

Hi Xavier, I have some additional info for you. I’m still trying to find out whatever I can. ;) It appears the two symptoms I am reporting may be more closely related than I previously thought. It looks like in both cases, the index.html is not getting written out. Here’s what I did:

1.in the workspace folder, deleted all folders.

2.loaded my plot file. 10 folders appeared in the workspace directory. None contained a “SIM…..” folder.

3.clicked “Run Simulation”. One of the 10 folders contained a “SIM” folder, which looked to be the same format as when you simply export DHTML. the Index.html file was also nowhere to be found in the “SIM” folder.

Hope this helps!

#3

I’ve got your attached plot file. It is simple and nothing special, I can run its simulation or generate the DHTML for it.

It’s quite strange that the “index.htm” file is not generated on your side. There is no error occur during the generation. Is it possible that your antivirus or protecting system block that generated “index.htm”?

#4

I would say that’s very possible. I was just hoping to have a specific system setting to inquire with my IT admins before I point the finger at them. ;) I will talk to them to see if they have any ideas, and post back if/when we find a resolution.

Thanks for your prompt replies! I hope we get this straightened out.

#5

our IT network admins worked this out through email with EaSynth, and for the record, they said “The resolution was to give the Users group Modify and Write access to the EaSynth directory under Program Files and replicate that access down to the folder below.” They then set this in our group policy so that if we get additional licenses later on, it will be all set. It’s working just fine for me now. Thanks for your help!

#6

Glad to know the problem is solved. You are welcome.

#7

This question is now closed