1. Embed a group inside a container, e.g. a Tabs element

2. Try to select the embedded group with the mouse

The problem is that you can select the elements inside the embedded group but no matter how many times you click you can’t select the group itself. If you want to select the group you have to click on the Group_… text in the properties bar.

The same goes for a group inside a group.

4 answers

This may be improved by enhancing the the algorism to select embedded element. Since it is not very easy task, we may not do it very soon.

Meanwhile the “Path” links can help selecting the elements.


There is a problem with the “Path” functionality.

1. Click on an embedded group (an element in the group is selected)
2. Click on the “Group_…” path
3. Click on the Delete button

Now, only the selected element (from step 1) is deleted.

I’ve run through the different functions:

  • The “Delete” doesn’t work.
  • The “Cut” doesn’t work (it cuts the selected element (from step 1), but actually copies the other elements from the group.
  • The “Copy” works ok.
  • The “Extract” works ok.
  1. Thanks for reporting the bug :-)
  2. The V2.652 have fixed this bug:

    Bug_0279: Select a group member, then select the group from the "Path" link, the group can not be fully deleted or cut.

I have updated to 2.652, but the delete/cut problem is still there…

I’ve made a simple group containing a cirle and a rectangle and embedded it into a window element.

I click on the circle or rectangle and then on the “Group_…” path link. The group is selected but delete and cut still doesn’t work.

  1. My bad, the bug we fixed is different than the one you mentioned. The fixed bug is on group that is not embedded.

    Will fix the bug you mentioned in next update.
  2. V2.653 has this fixed :-)

I’ve just tried to:
1. Embed a group in a Window element
2. Select the group (I had to use the Path link)
3. Move the group

That can’t be done… I can’t move the group by mouse or arrow keys.

Is that intended?

  1. It is by the way possible to move a group inside a group.

    However, there seems to be some painting problems. When moving an embedded group, the plot is not properly refreshed until you release the mouse key.
  2. That's intended. When embedding, we create a group to wrap all embedded elements, if the embedded elements are groupped beforehand, the group will be directly used. The wrapper group offers the offset of content and can not be moved.

    We will check the painting problem after we come back.

This question is now closed