Hmm .. I really want to chalk this up to operator error, but I rebooted, restarted, loaded the simulation in IE and FF, and got the same result every time:

Reproduction steps:

1. Drag a rectangle to the plot

2. Add mouse over event to change cursor to pointer.

3. Add mouse out event to change cursor back to default.

4. Run simulation.

What happens:

The cursor does not change when you hover over the rectangle.

In FF, I think I saw it flash quickly, but 99.99% of the time, the cursor stays at default.

Windows XP, SP2. IE8 and FF 3.6.3

I’m 100% sure I had this working in 2.15 .. am I doing something wrong, or did cursor change actions get broken?



7 answers

Unfortunately it is a bug 😐

Actually V2.17 make a big change on the generated code for some elements. That changes cause this problem. We will fix it in next version.


This is reported as Bug_0184 and has been fixed in V2.20.


I think this issue may have cropped up again. Some of my plots have no problem with cursor change, but some do. Not sure what the differentiating factor is. Other mouse over events work, but not the cursor change.


Hi AJ, if you have a plot file that could reproduce the problem, please kindly send to us (, we will then take a look at it. Thanks.



There is a lot of proprietary stuff in our plot so I was trying to clean it up before sending. As I deleted stuff and tested the prototype the cursor changed worked. Any thoughts as to why this might happen?


After checking, the problem is caused by a “Global Mouse Move” event handler that force the cursor to default style. Removing that handler will have it solved.


Having the same problem again with v 3.40. Using it under Ubuntu 12.04 with java version “1.6.0_27”

  1. Hi Bruno,

    This thread is very very old, and it was targeting a very old version of ForeUI. Seems you saw similar behavior, but there is not that much chance to be the same issue.

    Could you please send your plot file to <a href="" rel="nofollow"></a>? We could help you to check it.
  2. Hi Vivi, thanks for your attention. I posted here because I don't want to create a new topic for the same problem.

    I've created a very simple file that's not working here and sent to you. Thanks.

This question is now closed