1. Add a Tabs element to your plot

2. Put a rectangle inside the Tabs container. The rectangle snaps to the top left corner.

3. Put a button inside the Tabs container and place it in the middle

4. Now move the rectangle below the to the button

The button is automatically moved to the top left corner making it hard to layout the elements inside

I’ve recorded a short video showing the issue:


Can this behavior be turned off? I would prefer that ForeUI made no automatic movements of elements.

8 answers

Hi Ulrich, we understand your preference but we have to implement it in this way for now.

As you can see, all elements that embedded into a tab is grouped automatically, what you have sawn is that group always snap to the top left corner of the container. It may be annoying for you but if we change this rule, that will bring more troubles: you will be able to move the group out of the tab’s region, thus you will not see the embedded content in the editing area, and you will not be able to select the group. Clicking the container region will not help since the group is not there:

That case is really bad because it could make some element “disappear” from the plot, the only way to find them out is to select them from the element selector. So we define this rule: the embedded group must be snapped to the top left corner of the container, so you will always be able to select the group (and its content) by clicking the container region. To workaround the problem you have met, you can add an invisible element (blue rectangle in the figure below) on the top left corner of the group to help doing layout.

We know it is not perfect yet. If you have any suggestion on improving this, we are listening.


I see your point, but I’m affraid that you by trying to help create a bigger a more annoying problem. One solution could be to simply make the border of the container be impossible to cross. Another solution could be to make the “lost” element fly directly back, if it is left outside the boundaries of the container.

Could you maybe make it impossible to move an embedded element outside the borders of the container?

Another issue: I would very much like to be able to edit the elements inside the container. I’m trying to double-click e.g. a table, but nothing happens.

The strange thing is, that if I drag the element outside the container and then double-click it, I can suddenly edit it. Then when I click the “green checkmark” button, the element disappears (as you have described).


I get your point, but I’m affraid thay by trying to help, you are causing a more annoying problem.

Could you make it impossible to move an element outside the borders of the container? Or maybe make the element fly back if it is placed outside the boundaries of the container.

Another issue: I would very much like to be able to edit elements embedded in a container. I’m double-clicking but nothing happens.

The strangest part is, that if I drag the element outside the container, I can actually double-click it and edit it. However, when I click on the “green checkmark” button the element disappears, as you have described.


Would it be possible to just disallow the user from moving the group outside its container’s boundaries? And disallow the container from being resized smaller than the bounding box of its contents? This is the behavior I’ve observed in other programs. If I place it in a container, I want it inside the container. If I want it somewhere else, I take it out of the container.


Hi Ulrich and pohldoug, sometimes the group need to exceed the container’s boundaries. For example, the group in scrollable container, it could be much bigger than the container…


As for the issue about editing embedded element, it is a bug that double-clicking embedded element can not open its editor, we will fix it ASAP. Meanwhile you can select the embedded element and then click the “Edit” button on the floating tool pane to open its editor.


I have many troubles working with containers and embedded elements – even just removing it, seems to be impossible.

Is the issue of this topic mentioned solved now?


Hi Seb, this thread has nothing to do with the problem you are facing, and the issue in this topic has been solved. Next time please don’t reply the old thread like this.


This question is now closed