If I create or open a sample plot, press Run Simulation, I it tells me “Action in Progress” and does not do anything else. I have the trial version that is just a day old. Am I missing something here?

19 answers

Hi Nigel,

Can you tell us what is your default web browser? and what OS are you using? We’ve tested IE/FireFox/Opera in Windows and Opera in Mac OS X. We haven’t met this problem before.

BTW, you can try exporting the plot to DHTML, and run it locally, it has the same effect with “Run Simulation”.


Ok I am using XP SP 3 / Firefox 3.5.2. I have tried the DHTML and it works but the run simulation does nothing.


That’s odd… Are you using the .exe installer or the .tar.gz bundle? Do you know your JRE version?


Yesterday I downloaded ForeUI_Setup.exe 19.8Mb. Using Sun Java 6 and just installed update 14. I think the simulation might have run yesterday but I am not sure. I have restarted FireFox and ForeUI.


Do you find something suspicious in the log file (log/foreui.log)? If you have any new info, please let us know.


ForeUI and Velocity logs are empty. I will try rebooting at lunchtime.


We are in GMT+8 so it is PM 11:00 now. I will come back to you after 10 hours 🙂


I have the same question. I click “Run Simulation” and it starts Internet Explorer as I would expect. Internet Explorer warns me that it an ActiveX control is attempting to run. I select “Allow Blocked Content”. The screen changes, but it is completely blank. Please help. Thanks!


I forgot to mention, I am running Internet Explorer version 7. To be exact, 7.0.6001.18000.


Hi Cary, after you click the “Allow Blocked Content”, have you saw the “ForeUI Simulation Loading” text?

Another possibility is that your first page is empty? The simulation will start from the first page, if you put your content on the second or latter page, you will see the blank first page. You can use PageUp and PageDown to switch current page (IE’s status bar shows the page number).


Yes, I saw “ForeUI Simulation Loading” up until I selected “Allow Blocked Content”. I double-checked and the first page is not blank.

I clicked on the refresh button in Internet Explorer and I briefly saw “Errors on page” in the lower left corner. Could there be an error in the generated page?



Ok, it seems that a script error occured and it block the page loading. Can you tell us more details about this error? You can double click the “Errors on page” in the lower left corner to show more details.

Or maybe you can tell us how to make a page that can reproduce this problem? If you don’t mind you can send your plot file to Thanks.



I found the problem. I did not have access to the location under C:Program Files. If I saved the file out as raw .dhtml under My Documents, it worked fine. I’m sure if I increase my privileges, the Run Simulation will work.


Hi Cary, this information is very useful to others that meet this problem, thank you.


I’m having similar issues with “Run Simulation” not working. Downloaded the 1.6 trial version today. I’m running ForeUI under Windows Vista. Saved my plot.
Selected “Run Similation”
Get error message in Firefox 3.5.3 that says “/C:/Program Files/EaSynth/ForeUI/workspace/6BE742703BD5EADA0CA5B707E37BB4A7/SIM1254672729651/index.htm.

Check the “/” before the reference to the hard drive.

I get a similar message when I try “Run Simulation” on any of the sample plots.



Hi Deborah, as Cary mentioned above, it may be caused by the privilege limitation. ForeUI try to save the temporary files to a workspace directory under “C:/Program Files/”, this is forbidden in Vista by default (unless you are running with an administrator account).

We will move the workspace directory to the preferred folder in the next version, which will solve this problem. Before that you can workaround this by using administrator account, or increase the privilege of your current account.


V1.65 has moved the output folders to the system preferred user directory, that should solve this problem.


I have just downloaded the trial version for Mac OSX. When I click “Run Simulation”, it shows the progress bar but then nothing happened. I tried exporting the DHTML, but within those folders I could not find an index file to load.

I really want ForeUI to work for us, but I have to overcome this problem in order to consider it for purchase.


Hi David,

The problem you met is most probably caused by permission settings or virus firewall. You can take a look at this thread:…

Hope that helps.


This question is now closed