Current (as of 21.09.2013 – V3.30) version is not working under Linux – tried Debian Wheezy and Ubuntu 12.04 LTS. Problem is with mouse interaction:

1. Menus are not working (after clicking on the menu name, it appears, after button release – disappears),

2. not able to select anything on the plot workspace – single clicking just places currently selected object.

Have tried 3 different Java VMs – OpenJDK 1.6, 1.7 and Sun(Oracle) JDK 1.6.

All other Java apps (Using Astah, Eclipse, few UML tools) are working fine.

11 answers

Hi Alex,

I just tried it with Ubuntu 12.04 LTS, using OpenJDK Runtime Environment (IcedTea6 1.12.6) (6b27-1.12.6-1ubuntu0.12.04.2), and I could not reproduce the issue you mentioned.

So far I have no idea about issue #1. As for issue #2, it seems that you were using the “single-click, then drag and drop” mode to add element into plot, which is introduced in this page:….

If that is the case, you could press ESC or right mouse button to return to normal mode.


Thanks for response!

I have tried it again on Debian Wheezy – on the clean setup in the XEN VM over VNC, and have the same issue. Don’t know, what it related with…

Seems like mouse interaction is completely broken, and it’s not related to “single click” mode, unless it’s turned on by default. Pressing “esc” or right mouse button not helping.

Maybe it’s specific to Debian Wheezy, but other java apps, also working with graphics, are working fine.

Have tried JREs:

sun-java6-jre 6.26-0squeeze1

openjdk-6-jre:amd64 6b27-1.12.6-1~deb7u1

openjdk-7-jre:amd64 7u25-2.3.10-1~deb7u1

Maybe it’s also related to my specific machine, but that would be crazy… As I wrote, other Java apps, including monsterous Eclipse, are working fine…


Hi Alex,

Thanks for the information. It is the first time that we receive the report of this issue. Could you send us your log files? You can find it in the “(userDir)/.foreui/log” directory. Hope we could find something useful in the logs.

You can send log files to, thank you.


Hello, ViVi,

Yes, I would be glad to send it… Where can I change the log level? have found only “info” which seems to be high enouth, but log is almost empty…

Is there anything like log4j or similar logger to configure?

Behavior of working with mouse is quite strange:

1. Select object on the sidebar

2. press the left mouse button on the workspace

As result, object is created immediately and mouse cursor (cross) is jumped right and down for some distance.

Mouse over the object let it show the border to change size, but pressing left mouse button just places another object on the workspace.

When selecting something in menu, until I keep the button pressed, popdown is visible, as soon as I move mouse or release button – menu popdown hides.

I suppose, that it could be something with mouse event translation to Java library, used in ForeUI – but have no idea, what is it.

Currently log file is almost empty (cleared the old one, as I tried different versions and made the test start again with V3.3):

– Cut –

[2013-09-24 15:38:51,790] [main] [INFO] Starting ForeUI V3.3 (V3.30 ) …

[2013-09-24 15:38:56,799] [main] [INFO] ForeUI started.

[2013-09-24 15:38:58,149] [AWT-EventQueue-0] [INFO] Load layout from file: layout.conf

[2013-09-24 15:39:54,254] [AWT-EventQueue-0] [INFO] Save layout to file: layout.conf

– Cut –

BTW – I may provide you a virtual machine access (over VNC), where issue is reproducible.




Hello Alex,

You can add this line into the “settings.xml” file (under the (userDir).foreui/conf directory) to change the logging level to debug:

<entry key=”misc.log.level”>debug</entry>

According to the mouse behavior. After you select object on the sidebar, and before pressing left mouse button on the workspace, how does your cursor look like? Is it a pointer or cross lines?

The behavior you describe is quite similar with the mode to create object by single clicking and dragging. It seems that your system is always sending the “Right Mouse Button Pressed” events to ForeUI. When you press object on the sidebar, a “right mouse button pressed” event comes and that generate a “Click” event, which trigger the special mode to add element by press and drag. Also the menu disappears because “right mouse button pressed” event is received.

Maybe you could check your mouse first, to make sure it works correctly?



Ok. have changed the debug level. As far as I can see, no anything usable, except, probably Apache Velocity logs.

So, main log:

– Cut –

[2013-09-24 15:38:51,790] [main] [INFO] Starting ForeUI V3.3 (V3.30 ) …

[2013-09-24 15:38:56,799] [main] [INFO] ForeUI started.

[2013-09-24 15:38:58,149] [AWT-EventQueue-0] [INFO] Load layout from file: layout.conf

[2013-09-24 15:39:54,254] [AWT-EventQueue-0] [INFO] Save layout to file: layout.conf

[2013-09-28 01:14:07,801] [main] [INFO] Starting ForeUI V3.3 (V3.30 ) …

[2013-09-28 01:14:07,803] [main] [DEBUG] Checking JRE…

[2013-09-28 01:14:07,803] [main] [DEBUG] Checking for command line mode…

[2013-09-28 01:14:07,803] [main] [DEBUG] Initializing GUI mode…

[2013-09-28 01:14:07,805] [main] [DEBUG] Setup look and feel…

[2013-09-28 01:14:08,138] [main] [DEBUG] Prepare launching…

[2013-09-28 01:14:08,268] [main] [DEBUG] Synchronizing user folders…

[2013-09-28 01:14:08,374] [main] [DEBUG] Loading initial plot…

[2013-09-28 01:14:08,374] [main] [DEBUG] Loading plugins…

[2013-09-28 01:14:08,375] [main] [DEBUG] Loading main framework…

[2013-09-28 01:14:08,498] [main] [DEBUG] Fix settings if needed…

[2013-09-28 01:14:08,533] [main] [DEBUG] Initializing GUI components…

[2013-09-28 01:14:08,534] [main] [DEBUG] Initialize docking framwork…

[2013-09-28 01:14:08,989] [main] [DEBUG] Initialize menu bar…

[2013-09-28 01:14:09,256] [main] [DEBUG] Creating welcome page…

[2013-09-28 01:14:10,272] [main] [DEBUG] Initialize tool bar…

[2013-09-28 01:14:10,295] [main] [DEBUG] Initialize search pane…

[2013-09-28 01:14:10,421] [main] [DEBUG] Initialie outline pane…

[2013-09-28 01:14:10,502] [main] [DEBUG] Initialize image library…

[2013-09-28 01:14:10,651] [main] [DEBUG] Initialize system property pane…

[2013-09-28 01:14:10,685] [main] [DEBUG] Initialize custom property pane…

[2013-09-28 01:14:10,765] [main] [DEBUG] Initialize tool pane…

[2013-09-28 01:14:10,901] [main] [DEBUG] Initialize plot settings tool…

[2013-09-28 01:14:10,904] [main] [DEBUG] Initialize zoom tool…

[2013-09-28 01:14:10,938] [main] [DEBUG] Initialize UI theme…

[2013-09-28 01:14:10,946] [main] [DEBUG] Loading theme from /opt/ForeUI/theme/WindowsXP.thm

[2013-09-28 01:14:11,458] [main] [DEBUG] Loading theme from /opt/ForeUI/theme/Windows7.thm

[2013-09-28 01:14:11,630] [main] [DEBUG] Loading theme from /opt/ForeUI/theme/HandDrawn.thm

[2013-09-28 01:14:11,705] [main] [DEBUG] Loading theme from /opt/ForeUI/theme/MacOSX.thm

[2013-09-28 01:14:11,793] [main] [DEBUG] Loading theme from /opt/ForeUI/theme/Wireframe.thm

[2013-09-28 01:14:11,879] [main] [DEBUG] Initialize behavior pane…

[2013-09-28 01:14:12,083] [main] [DEBUG] Initialize page management…

[2013-09-28 01:14:12,131] [main] [DEBUG] Initialize plot tabs view…

[2013-09-28 01:14:12,236] [main] [DEBUG] Initialize element sources…

[2013-09-28 01:14:12,791] [main] [DEBUG] Initialize hot keys…

[2013-09-28 01:14:12,805] [main] [DEBUG] Initialize snap system…

[2013-09-28 01:14:12,805] [main] [DEBUG] Packing GUI…

[2013-09-28 01:14:12,900] [main] [DEBUG] Showing main window…

[2013-09-28 01:14:12,940] [main] [INFO] ForeUI started.

[2013-09-28 01:14:14,849] [AWT-EventQueue-0] [INFO] Load layout from file: layout.conf

[2013-09-28 01:14:15,073] [AWT-EventQueue-0] [DEBUG] Rendered the area with 1 ms

[2013-09-28 01:14:15,363] [AWT-EventQueue-0] [DEBUG] Rendered the area with 0 ms

[2013-09-28 01:14:15,429] [AWT-EventQueue-0] [DEBUG] Rendered the area with 0 ms


[2013-09-28 01:18:25,856] [AWT-EventQueue-0] [DEBUG] Rendered the area with 11 ms

[2013-09-28 01:18:27,511] [AWT-EventQueue-0] [INFO] Save layout to file: layout.conf

[2013-09-28 01:18:29,626] [AWT-EventQueue-0] [DEBUG] Rendered the area with 4 ms

– Cut –

And more interesting – velocity.log:

– Cut –

2013-09-28 01:14:08,320 – Log4JLogChute initialized using file ‘/home/wakizashi/.foreui/log/velocity.log’

2013-09-28 01:14:08,320 – Starting Apache Velocity v1.6.2 (compiled: 2009-02-19 16:29:46)

2013-09-28 01:14:08,320 – Default Properties File: org/apache/velocity/runtime/defaults/

2013-09-28 01:14:08,320 – Trying to use logger class org.apache.velocity.runtime.log.AvalonLogChute

2013-09-28 01:14:08,320 – Target log system for org.apache.velocity.runtime.log.AvalonLogChute is not available (java.lang.NoClassDefFoundError: org/apache/log/format/Formatt

er). Falling back to next log system…

2013-09-28 01:14:08,320 – Trying to use logger class org.apache.velocity.runtime.log.Log4JLogChute

2013-09-28 01:14:08,320 – Using logger class org.apache.velocity.runtime.log.Log4JLogChute

2013-09-28 01:14:08,323 – ResourceLoader instantiated: org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader

2013-09-28 01:14:08,334 – ResourceCache: initialized (class org.apache.velocity.runtime.resource.ResourceCacheImpl) with class java.util.Collections$SynchronizedMap cache map


2013-09-28 01:14:08,336 – Loaded System Directive: org.apache.velocity.runtime.directive.Define

2013-09-28 01:14:08,336 – Loaded System Directive: org.apache.velocity.runtime.directive.Break

2013-09-28 01:14:08,337 – Loaded System Directive: org.apache.velocity.runtime.directive.Evaluate

2013-09-28 01:14:08,338 – Loaded System Directive: org.apache.velocity.runtime.directive.Literal

2013-09-28 01:14:08,339 – Loaded System Directive: org.apache.velocity.runtime.directive.Macro

2013-09-28 01:14:08,340 – Loaded System Directive: org.apache.velocity.runtime.directive.Parse

2013-09-28 01:14:08,341 – Loaded System Directive: org.apache.velocity.runtime.directive.Include

2013-09-28 01:14:08,342 – Loaded System Directive: org.apache.velocity.runtime.directive.Foreach

2013-09-28 01:14:08,365 – Created ’20’ parsers.

2013-09-28 01:14:08,370 – Velocimacro : “velocimacro.library” is not set. Trying default library: VM_global_library.vm

2013-09-28 01:14:08,371 – Could not load resource ‘VM_global_library.vm’ from ResourceLoader org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader:

org.apache.velocity.exception.ResourceNotFoundException: ClasspathResourceLoader Error: cannot find resource VM_global_library.vm

at org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader.getResourceStream(

at org.apache.velocity.runtime.resource.loader.ResourceLoader.resourceExists(

at org.apache.velocity.runtime.resource.ResourceManagerImpl.getLoaderForResource(

at org.apache.velocity.runtime.resource.ResourceManagerImpl.getLoaderNameForResource(

at org.apache.velocity.runtime.RuntimeInstance.getLoaderNameForResource(

at org.apache.velocity.runtime.VelocimacroFactory.initVelocimacro(

at org.apache.velocity.runtime.RuntimeInstance.init(

at org.apache.velocity.runtime.RuntimeInstance.init(


at com.easynth.foreui.util.return.(Unknown Source)

at com.easynth.foreui.MainApp.main(Unknown Source)

2013-09-28 01:14:08,373 – Velocimacro : Default library not found.

2013-09-28 01:14:08,373 – Velocimacro : allowInline = true : VMs can be defined inline in templates

2013-09-28 01:14:08,373 – Velocimacro : allowInlineToOverride = false : VMs defined inline may NOT replace previous VM definitions

2013-09-28 01:14:08,374 – Velocimacro : allowInlineLocal = false : VMs defined inline will be global in scope if allowed.

2013-09-28 01:14:08,374 – Velocimacro : autoload off : VM system will not automatically reload global library macros

– Cut –

And, as I wrote before, I have checked the mouse – pardon, this is my working development system (meanwhile, all development is going in the VMs or chroot/jail environment, so it doesn’t affect system with XOrg and all sorts of GUI).

If that will helps, screen resolution is 1920×1200, and sometimes for the some time ForeUI working if window is not maximized. If window is maximized – it’s not working.

Also, cursor becames “right size change” type – like where is an object to change, but on completely new drawing pane – just at some position of the screen.

I don’t know how can it be 🙂 For all my 20 years of programming I see such crazy behaviours first time 🙂 (always hated interpreted languages, all sort of things is possible with these, assembler and C are the best 😉


HI Alex,

Thanks for the logs. I believe the velocity log has nothing to do with the issue, since the velocity engine is only used when generating HTML5 simulation.

However your description of the issue made me recall something. We have ever received a report of issue related to the maximized window — the mouse cursor iis not really at its position. I am not sure if these issues are connected. May I ask if you are using multiple monitors? I doubt if that is related.


Hello, ViVi,

Ok. I supposed that, as Velocity is just a template engine.

No, it’s not with multiple monitors. But while moving cursor across the empty workspace in maximized application window, it changing icon – sometimes it’s “right side resize” icon, but mostly just a thin cross.

But that still not explain why menus are not working.




It seems that your system keeps sending the “Right Mouse Button Pressed” events to ForeUI, and that could explain all behaviors you mentioned. HoweverI have no idea how could this happen……


Hello ViVi,

Have no idea either, as most of my software (which sometimes is really crazy written :)) working normally…

Ok, I have planned the system upgrade next week, maybe another version of graphics environment will solve it.

Thank you for your time, hope that ForeUI will work later. I like this software piece, but unfortunately, can’t use it in current nvironment…




The issue is know already. End of August, I wrote a E-mail (see below) to the support with a link to some videos which show the behavior. The videos are still there (““).

They never ask for more details but they never gave a feedback too….

—— my mail from 29. Aug. 2013 ————————————————————–


Unfortunately ForeUI is not working properly.

If ForeUI runs in full screen then it is not possible to click on some menue entries. After some time and/or resizing some screen areas , moving the cursor in menus cause highlighting other entries far away from the cursor.

Some of these effects are shown in a video on

If ForeUI runs not in full screen mode the most of the effect disappears. But some effects are still happen e.g tool tips don’t stays forever until ForeUI is terminated.

All these problems allows not to work productive with ForeUI.

The java engine is “java-6-openjdk-amd64”.

I hope you can find a reason for these misbehavior.

Best regards

—– and the answer from ViVi ————————————————————–

Hi Urs,

Thanks for reporting the issue and we are sorry for not replying you faster. I have created a ticket for it and our development team will work on it ASAP. If we need more details about this issue, we will let you know.

Best Regards,


  1. Hello Urs, we are sorry that we did not come back to you early.

    We know you do meet the issue, but this issue is not reproducible on our side. Please understand that we have to focus on some priority issues first, which are confirmed by more users. So far no other user (at least in this forum) confirm the same issue, we could not put this issue on priority, thanks for the understanding.

    It is also possible to be a kind of software conflict: maybe another software you installed affects ForeUI's behavior. Have you installed any software that may intercept (or generate) mouse events? Have you ever reproduced this issue on other machine?

This question is now closed