1. Add some behaviour to an element

2. Select the line(s) you want to remove

3. Press the DELETE key

Nothing happens.

6 answers

It seems related to the focus. If the mouse cursor move into the plot edit area, the behavior editor will lose its focus and the delete key will not work. Is it the problem you mentioned?


No, it is not a matter of focus. I simply cannot delete anything in the Defined Behaviours with the DELETE key no matter where focus is.


Hi Ulrich,

I tried many times and it seems related to the focus. Could you double check it?


I have also tried it many times now, and no matter where my mouse cursor is placed, I cannot delete anything in the Defined Behaviour dialog when the DELETE key.

If I click directly on the “line” I want to delete and leave the mouse there and then press DELETE nothing happens.


Maybe your DELETE key on keyboard is broken? I am just kidding 🙂

But I tried on several different machines and I just can’t reproduce it.

Considering you are facing other problems related to hotkeys:…

Is it possible that you have installed any software may intercept/affect hotkeys?


A miracle just happened 🙂

I docked the “Defined Bahaviors” panel and undocked it again, and now everything works fine again:

– CTRL + B both shows and hides the panel

– The DELETE key works

– The width of the Notes area is remembered correctly

– Focus is now placed correctly in the “Select element as Behaviour owner” dialog

So something strange happened in the panel which had a lot of side effects, but it was reset when I docked and undocked it.

  1. Are you looking into this?

    It has happened a couple of times since the above post.
  2. We still not able to reproduce the issue you mentioned. As you said the problem disappear after docked and undocked again, did the issue re-appear after that?
  3. Yes, as I write above it has happened again after reporting the defect.

This question is now closed