I have some text labels in my plot file using the default font (I use Windows XP look and feel). The font looks like Arial, Verdana or Tahoma.

When I run it in simulation, the font is changed (to a font that looks a bit like Times New Roman). :o(

I haven’t experienced this before version 1.70.

8 answers

Thanks for reporting, it is a regression caused by the Bug_0104 fixing (which is to solve the asian font displaying issue).

Sure we will fix it in next version.


This is reported as Bug_0108 and has been fixed in V1.72


Is it possible that the problem reoccur?
I’m using the latest 2.15 version.

  1. Hi, from V2.00, the default font is changed to "Dialog". You can specify the default font in the settings window (under the "Plot" tab).

I’m experiencing this issue again (in both IE8 and Chrome).

In simulation all text in tables, labels and texteditboxes is shown in something that looks like Times New Roman.

I’ve changed the default font to Verdana, but it has not effect.

This is very critical as I’m creating a prototype for a usabilty test in 3 weeks.


Hi Ulrich, I set the default font to Verdana and run a test, and my result is below:

I think you can check two things:
1) check the “elements.css” file in the generated “styles” folder, to confirm if the “font-family” is set to “Verdana”;
2) check if your system has installed the Verdana font.


Verdana is installed on my computer.

I’ve double-checked the font settings in ForeUI (Verdana is selected) and checked the generated elements.css. Verdana is not a part of the font-family.

font-family: “Dialog”;

I’ve tried both the “Run Simulation” and “Export DHTML”.

What should I do?


Hi Ulrich, can you confirm your text element is using the default font? If the font of text element is not <default>, it will override the default font settings.

Also please confirm your default font is set like below:


Woops, I missed the “Specify Default Font” on the “Plot” tab.

I got a bit confused about the “Change Default Font” on the “General” tab.

Now, it’s working fine…



This question is now closed