Hello, thanks for your great product. But i have an issue in Ubuntu 14.04. I have 2 language input methods – english and russian, whenever i switch to a russian input method, my hotkeys won’t work. Is it possible to fix that?

11 answers

Hi Alexander,

It seems that your Russian input method hooks all input and doesn’t forward to ForeUI. That should be considered a bad design of the input method and we could do nothing on it.

I am using Mac OS, and my ForeUI’s hot keys still work when using the system built-in Russian input method.

Maybe you can try a different input method?


Well, tried arabic input and got the same picture. In LibreOffice i can use hotkeys while on a russian/arabic. If it’s a bad design, why it does work in LibreOffice applications?


Some application may use more native way (something like system event hook) to get higher priority for hot key processing. ForeUI is not in that case, it only receive keyboard input when it has focus, if another application (input method) takes its input, it wouldn’t know about your input.

As a Java developed application, this is the recommended way to process the hot keys, so I couldn’t see what we could do on this.

A good input method should forward the input back to the main application, or even better, it doesn’t take the focus, so the main application could still receive input events. The input methods in Mac OS work in this way.


So, there’s no way to set language independent hotkeys? Every Linux user will face that issue…


I don’t have ubuntu 14.04 on hand, but I have a machine that installed ubuntu 11.10. I just tried using the system built-in Russian input method on ForeUI, and the hot keys are all working fine.

Although my ubuntu version is different, it has small chance that higher version of ubuntu changed a lot and bring this issue. Could you let me know the name of input method you were using, and which hot keys are affected? Thanks.


Here’s an image:


E.g. Ctrl+P which opens “Pages” panel is not working while on russian input method.


Thanks for the screenshot, it is exactly the input method I tried. On my end all hot keys are working fine under Russian input method, including Ctrl+P


Please, could you try Ubuntu 14.04?


Although my testing is not done on 14.04, it still proves that is not a bug in implementation.

Even if Ubuntu 14.04 changed a lot to cause this problem, the way to “fix” it will not be cross-platform and thus has very low priority.

I believe there is bigger chance that the issue is caused by your software environment. There are other Ubuntu users who are using ForeUI, and we haven’t received any report of this issue before.

BTW, if someone who use Ubuntu 14.04 and could reproduce this issue, please let us know.


Well, i have “clean” Ubuntu 14.04 on my virtualbox and it has the same issue. You could try that too. Get virtualbox and install Ubuntu 14.04 then launch your software.


This question is now closed