Hello ladies and gentlemen,

using the great software ForeUI with selfcreated .fce packages I encountered an usability issue.

When importing some .fce with many images, those will show up in the image dock.

To clean up I use “Optimize Image Usage” with “Remove Duplicated Images” checked.

However this great function ONLY relink to existing images, which works fine.

It would be better, if the relinking went successfull also to REMOVE(as said in the checkbox) the old imported images, since they are not used anymore.

As of now, I delete them by hand.

Thank you 🙂

4 answers

Hi Oleg,

I think the “Remove Unused Images” option is just for that, isn’t it?

  1. Hi ViVi,
    yes I know about this function.
    In my case I use about 20 Images, which are not used statical, but replace (Set "ImageBox_1"s Image Source to "img2") each other dynamical depended on user actions.
    So if I do like you suggest, I will delete them also and can ́t use them dynamicly in the simulation as supposed.

    I hope you got my point :)
  2. I think I get your point this time :-)

    I just tried your case and I think there are two bugs now:

    1) The "Remove Duplicated Images" option doesn't really remove anything, it just relink the image reference to the first copy of the same image. If you do not choose the "Remove Unused Images" option, those duplicated images will remain in your plot, although nobody is using them.

    2) Even the relink is not working perfectly. The action to dynamically set ImageBox's source image will not get updated during the relink.

    Do you agree?
  3. I can confirm the 1st point, thats what bothered me when I read "REMOVE Duplicated Images".

    I had no problem with the 2nd point, because I kept the same image order in the .fce and my main plot.

    But you are right, if I would have different image order in the .fce with "Set image source" function, than in my main plot, it would have trouble to find the right image.

So it seems to be more a bug, than an improvement.

If a moderator could change the topic to “problems”, it would be great 🙂


Changed it to “problem” now. We will have it fixed in next release.


These two issues are fixed in the newly released V3.80 SP2

  1. Confirm, that this works now. Good job :)

This question is now closed