When I set a TextEditBox to the value of a Table.cell i have the problem that i loose the format.


Text in the Table Cell:

“GnRaiser, nnew Linie”

Tabel -> TextEditBox:

“GnRaiser,&nbsp;< br>new&nbsp;Linie”

Tabel -> TextBox -> TextEditBox:


new Linie”

I have no Idea way all my Spaces in the text were transformed to “nbsp;” when i get the value of the cell direkt.

If i first but the cell to a TextBox and then put the TextBox.text to the TextEditBox it works perfekt.

I also tried to put the cell.value first in to a String but this also didn’t worked. What do i to wrong? Or is the step over the TextBox the only way?

2 answers

The spaces in text are converted to &nbsp; because the web browser can not display continuous spacing.

However the element should convert the content back to normal string when user try to get the value back.

The get/set value action for Table is not good enough, it should be improved and should work like how the TextBox is doing. As Xavier mentioned, this will be improved in V3.0.


Ok thanks,

hope V3.0. ist coming soon.


This question is now closed