When I insert text from one row of table cells to another using “Set Cell Value”, the target table rows greatly increase in height from 25 to about 75 pixels. Is there any way to keep this from happening?

Also, How can I concatenate the contents of two cells to insert into a target?

[Table_Records.cellValues][{SourceIndex}][2] + ‘ ‘ + [Table_Records.cellValues][{SourceIndex}][3]

Creates a run-time error in IE.

9 answers

Maybe you could cancatenate two properties with a temporary property, like this:

The expression parser is re-created in the coming V3.0, so you will not need this trick on V3.0


Thanks. Any thoughts on the row height problem?


As for the row height problem, I could not reproduce it on my side. Could you show me the table structure and the actions?


I got a very simple case of row deletion and append to work:

My production version, however, just quits running at the delete row. Is there a way to send you the 4ui file?


Hi Alan, you could send your 4ui file to


Hi ViVi,

That worked. Here’s a new one. The Marked line generates a “TypeError” exception in Chrome:

The Javascript looks like this:

setCustomProperty(“CurrentRecord”, Table_getCellValues(“Table_3”)[getCustomProperty(“Index”)][1]);

This is Table_3

and Index:

customPropertyMap[“Index”] = new Object();

customPropertyMap[“Index”].name = “Index”;

customPropertyMap[“Index”].type = 0;

customPropertyMap[“Index”].value = 0;


Hi Alan,

According to to context, the “CurrentRecord” property should be in String type, and you should uncheck the “Set as Number” option of the Set Global Property action.

If that still not work, you can send us the plot file.


Same result. I sent you the file.


Table handling around dynamic row creation appears to be very buggy.

Try to select a row in Table 4 of the file I sent you. You can’t and selected row always returns 0.

Unless the table is physically sized to have no rows in the layout editor, the loop that deletes any rows from the table is unreliable. Look at my Table_4 handler for an example.

Suggestion. How about a table command that removes all non-header rows as a single operation?


This question is now closed