when installing the 3.40 version have disappeared all pictures I used in my prototype, in fact I can not insert new images for the gallery is empty. Can you help?

6 answers

Hello Antonio, there was a thread that discuss the same (or similar) issue.…

If you open your plot file and find those images are gone, please don’t save your plot, thus your plot file will still keep those images.

I would like to suggest you to try the option in the settings window (in misc tab), to enable the memory cache for images. It has some chances to fix the issue for you.

Let me know if it helps.


Hi Vivi, I have already enabled the cache for images, plus I increased the cache to 1000 Mb to avoid problems but the plot was saved. I still have the same problem but I’ve also noticed that in this plot I can not add pictures and I can not run a simulation. Any idea?

Thank you very much for everything.


Hi Antonio, could you please send us your plot file to We will check the file for you.


Hi Vivi, a few days ago I sent the plot that was giving me the problem with the images but I have started to make a new plot and I have similar problems. At first all goes well but when the plot has multiple pages and images I have trouble inserting new images. Would you like more information or send a problem you who know and are you solving?

Thank you very much.


Hi Vivi, problem solved. I changed the settings and I left as I show below. It seems that the problem happens when I use cache memory for pictures, turn off this option as the problem disappears.

Thank you very much.


Hello Antonio, glad to know the problem is solved. That option is turned off by default, and could be used when ForeUI could not access the hard-disk (because of limitation to visit network driver, or permission reason etc.). Once that option is turned on, ForeUI will cache the image data in memory instead of hard-disk, and will consume more memory. If the plot is big and contains a lot of image data, the memory will run out and cause some problems. I guess that was what happened to you.


This question is now closed