My Windows Vista Ultimate on Asus G1S constantly crashes after using version 1.25+. It does not do this using version 1.23 and below. The crashes are random in time, but always triggered after using and closing ForeUI. Tried the installed packages and the zip ones (with preloaded JRE 1.6 update 14) and neither helps.

It’s not Java itself since I am using JRE 1.6 Update 14 and Flex Builder daily and never had a single crash.

Again, no crashes and BSOD unless I start and close ForeUI. It takes no more than 2-5 min. after closing it to show BSOD.

Any idea or hint?

9 answers

I’ve checked the update history, but can not find any clue yet.
As a Java application, it is not easy to make BSOD. Since you mentioned v1.22 (we don’t have v1.23) and below works fine, is it possible that some addresses of the memory is not accessable?
Can you paste the log file (log/foreui.log) content, it may give us more information.
You may also check your system log, may be there are clues…


Narrowed the issue – starting ForeUI and then Flex Builder crashes the machine in minutes.

So might be more a Java issue than ForeUI.

Tested on:
Asus G1S with Vista Ultimate 32-bit SP2
installed JRE6 update 14
ForeUI 1.30 which points to the installed JRE above
FB 3.0.1

And I am giving up since 5 crashes in 40 minutes testing doesn’t sound good, especially at work 🙂


Thanks for the info, so far we can not reproduce the problem in our testing machines. Have you tried it on another machine?


Unfortunately I don’t.
Anyway, thanks for the will to help.


Old topic, but problem never resolved.

Many months later, I still have this same problem on this same machine. I took some time to clean and see what might be the issue. So far narrowed it to something in you code (from version 1.25 and up, including latest) and any JRE. Here’s what I did.

1. Upgraded to Windows 7 Ultimate 32-bit.
2. Got absolutely any updates.
3. Wiped out all custom Asus and 3rd party software drivers (let Win decides what to apply)
4. Installed latest JRE (1.6 Update 18)
5. Got latest ForeUI (2.17) and started it.
6. BSOD in 2 minutes without loading any other apps
7. Uninstalled JRE 1.6 and installed JRE 1.5 Update 22
8. Started ForeUI 2.17.
9. BSOD right away!
10. Uninstalled JRE 1.5 and installedlatest JRE 1.6 Update 18
11. Uninstalled ForeUI 2.17 and installed ForeUI 1.22
12. Working like a charm
13. No problems
14. No problems in 3 hours
15. Tested RAM with software ram checker
16. No problems after 2 hours extensive checks
17. Reverted to latest ForeUI (2.17)
18. BSOD in 2-3 minutes


Got some dump files during all these crashes (in case you need them let me know).

The annoying part is no problems with ForeUI at home. I am really curious to realize where is the actual problem. It’s very specific as far as I see but still it’s a problem which points to ForeUI code development somehow. Again, no problems whatsoever prior to version 1.25.

I would appreciate any hints, ideas and/or suggestions 🙂


Hi Dimitar,

Can you try running the online demo in your web browser? Just launch this page: This may help us to narrow the issue.

Are you using the administrator account? If so the log files under the <ForeUIInstallDir>log folder may contains some useful information. Can you send us those log files? (to

Actually if you are using the ForeUI installer for Windows, you don’t have to install any JRE by yourself since the installer already contains a JRE for ForeUI to use. Although it is not related to the issue.

BTW, according to your description, this looks more like a memory issue. But since you have checked the RAM… I have no clues now.


Take 2.

1. I saw there is an updated JRE 1.6 update 19, so I removed update18 and added update 19.
2. Uninstalled ForeUI 2.17 (just in case :-), then reinstall it (Windows installer)
3. Downloaded 2.17 minimal bundle and unzipped it into c:. Fixed ForeUI.ini to point to the JRE isntallation (c:program filesjavajre6)

4. Then I started the online version (good call) in Firefox 3.6.2 and it worked without any issues. Waited for 20 min. then started opening some other apps which require JRE (Flex builder, SmartSVN, Ant). NO PROBLEMS.

5. To be sure closed Firefox (left any other apps), and started the online version in IE 8. Played around, did some work, etc. for 20 min. -> still NO PROBLEMS.

6. Closed everything, started the preinstalled ForeUI.exe and BSOD while loading the app.
7. After restarting, starting the minimal bundle ForeUI.exe and BSOD in 2 min.
8. Restarted again and started the preinstalled version of ForeUI (just to be sure), crash in 2 min.
9. Restarted, started the online version in Firefox, opened all my daily workflow apps – all quiet.
10. Still quiet for more than an hour.

So in short, prior to version 1.25 (Win installer or minimal bundle) -> no issues. Latest online version – no problems.

From 1.25 and up (including latest) Win installer and min. bundle – BSOD.

“log” folder under the installed version does not exist (beats me).
“log” folder under minimal bundle folder exists, but there are 2 empty files (foreui.log and velocity.log).

I have the minidump files for the latest 3 crashes (2 with Win installer and 1 with min. bundle) and if you need them, let me know.

I too thought might be memory or hard drive, did all checks just in case. But since older versions are fine and online too, and latest ALWAYS fails, I don;t think it’s a hardware problem anymore.

Well, I give up, gave you all details I can provide. For the time being will use the online version on this machine.

In case you have some hints please let me know.


Thank Dimitar for these details.

Since the online demo use the same content with the installed version, I can not figure out why they behave differently. Maybe it is an issue caused by software confliction…

If someone have more clues for this problem, please help.


Problem solved. How – no idea 🙂
It might be either of using:
– JRE 1.6 update 20
– ForeUI 2.302
– all updates of W7 this morning

Just to mention that last week with ForeUI 2.27 and JRE 1.6 update 19 it was crashing as always.

Whatever it is, it works (finally)!


This question is now closed