I have used this tool for a month and when I initially started I thought this was a mistake at my end but of late having repeatedly encountered this problem I am very sure this is a problem with this tool.

I have lost my work at-least 3-5 times and I have had to work weekends just to redo the work I had previously done.

Finally, the problem is I use foreUI, save my application and restart it the next day. I see a blank file with absolutely nothing. All my work is gone and it just pisses me like anything. It opens all the foreUI files except the last saved file( or the first file in the recent plots)

I m on a MAC OS. Memory 4 GB, 1067 MhZ DDR3. 2.66 GhZ Intel Core i7. I think these details are irrelevant as my company recently purchased this mac for me but still would like to provide these details.

7 answers

Hi Varun,

It is not easy to lose your previous work in ForeUI, since it will auto save your plot file for every 3 minutes (the auto saved file has “_autosaved” postfix).

Do you remember which directory did you save your plot file into? Have you checked that directory with Finder? Please confirm if your plot file is still there.

There is a “Recent Folder…” button in the plot open dialog, you can click the button to switch directories that were recently used. Maybe you can find your plot file in another directory.

If you think your plot file is really gone and some errors happened in ForeUI, please send us your log files to for checking, thank you.

The log files can be found in “/Users/(username)/.foreui/log/” directory.



I did check the recent plot and directory section, it just wont open the last saved file. I think there is some serious problem with this tool when it comes to it’s last saved item. As I said it just happens a whole lot, eventually I started to e-mail myself the last saved file before I closed foreUI for the day( almost every-time I try to open the most recent plot). The steps you mentioned, I think those things are very intuitive on the software and I have been doing those steps without fail. As I said before I start pointing fingers at others I really dig hard to make sure I m not the one making errors.

Although I think this tool is really amazing but to be honest this situation scares me to introduce the tool to my manager. Imagine giving the presentation to the team and nothing is there, I would have been in that situation had I not started this extra e-mail steps in my workflow.

I am at my home now but I will send you the logs the first thing tomorrow morning but I really hope your company resolves this issue as I would have loved to introduce this tool to our team.

Thanks and have a good day Xavier.


I think I didn’t answer some of your questions

1. Plot file is still there with the same file name I gave.

2. I checked through the finder and the file itself was there in the location/directory but it was absolutely blank.

3. I tried loading the plot and in the preview section just before loading it used to show me the preview of the file with proper contents but as soon as I clicked on open or load in the popup. Everything was empty.



Hi Varun, thanks for the information.

From your descripiton, I think there is something wrong in the plot file (although I am not sure what it exactly is, and why it happens), so it is failed to be loaded (and keep blank in the editor).

Please send us your plot file, it might be recovered if we find out the error. Also please send us your log files, which will help us to locate and solve the problem.



I tried the other day to get the files for log from the location you have mentioned, it was surprising but there was no folder like that. Secondly as far as the file is concerned it’s something I worked this weekend to rework and do it again. I couldn’t share the file with you as it was a company confidential document and sharing outside the company might have been rather complicated. idk what the issue is but if there is any other way for me to give you the information helpful for you to figure out the problem please let me know.

  1. Hi Varun, the log folder should be there. I guess it is be hidden by default (since the ".foreui" directory name starts with a dot). You can configure your Finder to show the hidden directory.
    Here is how: <a href="; rel="nofollow"></a>

Hi Xavier,

This also didn’t seem to work for me. Sorry. I think I will take the e-mail route for now. It’s not something I am happy about but I m not the most technical person and installing external unverified apps on a office comp always makes me a bit skeptical. Anyhow I appreciate your help and time.

One thing I have to point out though is that your application never really gets installed on my system, a normal app on mac after the dmg file related installation asks the user to drag the application in application folder but with your application that pop up never comes up. So every-time I have to restart my computer, I usually install the dmg file again and start working. idk, maybe that’s a problem. I did try to drag your app from the left bars to the application folder but still app wont show up after I shut down this app.

  1. The .dmg file is the image of virtual driver, when you double-click to install it, it will temporarily mount the driver on your machine, just like you have a CD in your CD-ROM. To install ForeUI, you will need to drag the "EaSynth ForeUI" application from that driver into a place in your machine (desktop or application folder will all be ok), otherwise your ForeUI application will disappear when the virtual driver is unmounted.

Okay. Thanks. Usually this screen is always there for mac app installs as a last step. This never comes for foreUI. Maybe something you guys want to consider for future as this is a very common UI confirming installation of the app? Thanks

  1. Thanks for the suggestion, we will consider that.

This question is now closed