Downloaded 2.45 just now and decided to give the performance a quick test. The prototype stopped working for me; I can’t get past the initial page that shows two buttons.

The Firefox console reports the following error:

Error: missing ) after argument list

Source File: file:///Users/rdouma/Temp/v9_foreui245/scripts/elements.js

Line: 343, Column: 82

Source Code:

if (window.confirm("Weet u zeker dat u de zoekopdracht wilt dupliceren? Als u op "Ok" drukt zult u naar de nieuwe zoekopdracht gaan, die geinitialiseerd zal zijn met zoekcriteria van de opdracht die u dupliceert.")) {

See attached screenshot. So the problem seems to be that the Strings in the message are not escaped.

I can provide a link to a download of a zip with a working/non-working prototype and the .4ui file if required.

8 answers

Hi Remco Douma,

As you mentioned, the “ok” string in the message is not escaped. However this part is not changed in recent updates. So please provide a link to download the file, I will check it ASAP. Thanks.


Hi Xavier, thanks for your prompt response. Do you have an e-mail address I can mail you the link to? Just feels inappropriate to post a link with a prototype of an ongoing project for a customer publicly.


Sure, please send to, thanks.


Hi, I am experiencing the same behavior. I have copies of project files from v2_42 which function as expected. Using v2.45 the project exports, but I am unable to invoke any pages beyond the first page displayed. Attempted multiple browsers with the same result. Took a v2_42 saved file which exports fine under v2_42 and opened with v2.45 and ran immediate export with NO file changes. Same result, export completes, but pages fail to function properly. If needed I can send a copy of the project file in question.



  1. Hi John, you can check these thread to see if there is a match:
    <a href="; rel="nofollow"></a>
    <a href="; rel="nofollow"></a>
    You are welcome to send the file to <a href="" rel="nofollow"></a>, we can help you to check.

I also have the same issue just after upgrading to 2.45 – none of the links on the first page works and I get the following error:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E)

Timestamp: Mon, 13 Sep 2010 22:44:29 UTC

Message: Expected ‘)’

Line: 28

Char: 77

Code: 0

URI: file:///C:/Users/fretief/.foreui/workspace/02A11082A1D4D34402A814F49EE3435C/SIM1284417854261/scripts/elements.js


Remco Douma’s plot file has unescaped quotation marks in the message. This kind of issue is also mentioned in these threads:;;

In older versions this problem also exist but sometimes the web browser will ignore it. However in V2.45 seems all browsers can not live with this problem.

I agree with Remco Douma that escaping is kind of programming thing, ForeUI should handle this in the background. So we will make the enhancement soon.


I found the unescaped quotation marks as expected. Removed and the project now runs as expected.



I must have had the same issue but changed it without knowing as my project now also runs ok


This question is now closed